BTG Degraded Performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jul 06, 2020 - 21:08 PDT
Investigating
Our BTG processing is experiencing some performance issues at this time. Our Engineering and DevOps teams are actively investigating this issue, and we will will provide updates here as they become available.
Posted Jun 22, 2020 - 04:30 PDT
This incident affected: Digital Assets (Bitcoin Gold (BTG).