Scheduled Maintenance on app.bitgo-test.com

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 10:13 PDT

Investigating

In order to keep improving our services, BitGo will be performing a scheduled maintenance on the infrastructure hosting our applications at https://app.bitgo-test.com.
During this hour we expect staking service disruption.
Posted Jun 06, 2025 - 09:18 PDT
This incident affected: Testnet.