New User Sign-Ups Temporarily Disabled
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 21:39 PDT
Investigating
We have temporarily disabled new user sign-ups due to performance degradation. This is a precautionary measure to ensure the stability of our platform while we address the issue.

- New user registrations are currently unavailable.
- Existing users and services remain fully operational.

We are actively working to resolve the issue and will provide an update once new user sign-ups are re-enabled.

We apologize for any inconvenience this may cause and appreciate your patience. If you have any questions or concerns, please contact our support team at support@bitgo.com
Posted Oct 09, 2024 - 17:44 PDT
This incident affected: Platform.