Scheduled Maintenance to our Canton Validator

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 02:27 PST

Investigating

In order to keep improving our services, BitGo will be performing a scheduled Maintenance to our Canton Validator on Tuesday, February 17, 2026, between 10:00 AM - 1:00 PM EST
During this hour we expect some minor service disruption manifesting in our platform.

If you have any concerns about the availability of your account during this window, please reach out to our support team.
Posted Feb 16, 2026 - 02:20 PST
This incident affected: API, Wallets, Platform, Trade API (BitGo Trust Trade API), Trade (BitGo Trust), and Digital Assets (Canton).