Scheduled Maintenance on app.bitgo-test.com

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 11:44 PDT

Investigating

In order to keep improving our services, BitGo will be performing a scheduled maintenance on the infrastructure hosting our applications at https://app.bitgo-test.com.
During this hour we expect service disruption manifesting in our platform returning 500s.

If you have any concerns about the availability of your account during this window, please reach out to our support team.
Posted Jun 04, 2025 - 10:03 PDT
This incident affected: Testnet.