We are experiencing a delay with transaction broadcasting for a small subset of supported coins

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted May 20, 2025 - 16:47 PDT

Monitoring

We have identified the issue, implemented a fix, and are now monitoring.
Posted May 20, 2025 - 16:28 PDT

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 15:45 PDT

Investigating

We are experiencing a transaction delay with broadcast on the following coins:

algo
apt
avax
bsc
hbar
icp
osmo
polygon
sol
stx
sui
tao
Posted May 20, 2025 - 15:45 PDT