TRX Degraded Performance
Incident Report for BitGo
Resolved
Our Tron full-node upgrade is now completed and operational.
Posted Jul 15, 2020 - 19:31 PDT
Investigating
Our TRX processing is currently non-operational as we are preparing to upgrade our Tron full node. Please check here for updates.
Posted Jul 15, 2020 - 17:43 PDT
This incident affected: Digital Assets (Tron).