Issues with AVAX-C Transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 22:57 PST
Investigating
We are currently investigating this issue.
Posted Nov 17, 2022 - 10:21 PST
This incident affected: Digital Assets (Avalanche C-chain).