Issue with BTC transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 00:07 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2020 - 23:58 PST
Investigating
We are currently investigating this issue.
Posted Nov 08, 2020 - 23:47 PST
This incident affected: Digital Assets (Bitcoin).