Issue Affecting New User Sign-Ups

Incident Report for BitGo

Resolved

The issue has been resolved and we are continuing to monitor.
Posted Jan 19, 2026 - 14:39 PST

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 11:11 PST

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 09:33 PST

Investigating

We are currently investigating the issue.
Posted Jan 19, 2026 - 09:32 PST
This incident affected: Platform.