Delays processing deposits and intermittent errors building and broadcasting transactions for DOGE and DASH
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 05:22 PST
Investigating
We are currently investigating this issue.
Posted Jan 09, 2023 - 05:02 PST
This incident affected: API, Wallets and Digital Assets (Dash).