Issues processing DASH transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted May 23, 2023 - 01:00 PDT
Update
DASH mainnet has restarted block production. Our services for DASH are fully back
Posted May 23, 2023 - 01:00 PDT
Investigating
DASH mainnet has halted block production due to a bug in the DASH client. Deposits and withdrawals will not be processed until a fix is implemented by DASH developers.
Posted May 22, 2023 - 02:43 PDT
This incident affected: Digital Assets (Dash).