Login Service Temporarily Unavailable

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 10:43 PDT

Monitoring

Bitgo Platform experienced a temporary issue with login and website access. Services have been restored and our team is monitoring.
Posted Jul 10, 2025 - 09:37 PDT
This incident affected: API and Platform.