Issue Preventing Trade Placement

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 15:21 PDT

Investigating

We've identified an issue affecting a small number of customers who may be unable to place trades. Our team is actively working on a fix and we'll provide an update as soon as possible.
Posted Jun 18, 2025 - 14:21 PDT
This incident affected: Trade.