Issues with TestNet platform
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 06:32 PDT
Investigating
We are experiencing issues with testnet, users can't create new wallets and sign transactions. We are currently investigating this issue.
Posted Apr 11, 2023 - 04:17 PDT
This incident affected: Testnet.