Discrepancy in wallet Balances

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 13:32 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 12:45 PDT

Investigating

We are currently experiencing an issue where wallet balances are displaying incorrectly in the dashboard. Please note that this is a display issue only - underlying balances remain accurate and unaffected.

Our team is actively investigating the issue. We will provide an update as soon as more information is available.
Posted Jun 18, 2025 - 12:28 PDT
This incident affected: Wallets and Trade.