Issues accessing wallets in BitGo UI
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 17:23 PST
Investigating
We are currently investigating this issue, mainly we are having issues loading bitcoin (BTC) wallets. This issue is affecting UI and API clients.
Posted Feb 09, 2024 - 14:17 PST
This incident affected: API, Wallets, and Platform.