Delay in processing deposit/withdrawals for BSC

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 06:56 PDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 01:39 PDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 01:36 PDT

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 01:30 PDT

Investigating

We are currently investigating this issue.
Posted Jun 16, 2025 - 01:24 PDT
This incident affected: Digital Assets (Binance Coin (BNB)).