Delay in processing AVAXC transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 04:55 PST
Investigating
We are currently investigating this issue.
Posted Dec 05, 2024 - 01:26 PST
This incident affected: Digital Assets (Avalanche C-chain).