BSV Degraded Performance

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Jul 15, 2020 - 17:45 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 04, 2020 - 19:33 PDT

Investigating

We are currently experiencing degraded BSV performance. Our Engineering and DevOps teams are actively investigating this issue, and we will will provide updates here as they become available.
Posted Jun 04, 2020 - 17:05 PDT
This incident affected: Digital Assets (Bitcoin SV).