Withdrawals not working and inaccurate wallet balance for some coins

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Mar 02, 2023 - 22:15 PST

Investigating

We are currently investigating this issue.
Posted Mar 02, 2023 - 22:09 PST
This incident affected: Digital Assets (Bitcoin, Litecoin, Bitcoin Cash, Ethereum, ZCash, Polygon).