Delay in Support Request Creation

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 13:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2023 - 12:33 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 21, 2023 - 11:31 PDT

Identified

We have identified an issue with Support Ticket creation and are working to resolve as quickly as possible. You may experience a delay in response from Bitgo on Support Issues.
Posted Sep 21, 2023 - 11:31 PDT