Delay in processing deposit/withdrawals for Celo

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 01:10 PDT

Investigating

Delay in processing deposit/withdrawals for Celo
Posted Apr 14, 2026 - 01:07 PDT
This incident affected: Digital Assets (Celo).