Investigating Withdrawal issues for Go Accounts

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 14:18 PDT

Investigating

We are aware of an issue where users are unable to withdraw from Go account, our engineering team is investigating this issue.
Posted Sep 10, 2025 - 13:00 PDT
This incident affected: Trade.