BTC Degraded Performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Sep 11, 2021 - 10:31 PDT
Monitoring
A fix has been implemented and we are monitoring the situation.
Posted Sep 11, 2021 - 10:26 PDT
Investigating
Our BTC processing is experiencing some performance issues at this time and is falling behind chainhead. Our Engineering and DevOps teams are actively investigating this issue, and we will will provide updates here as they become available.
Posted Sep 11, 2021 - 09:32 PDT
This incident affected: Digital Assets (Bitcoin).