Issue processing BCH transactions
Incident Report for BitGo
Resolved
This incident has been resolved. All BCH transactions are processing nominally.
Posted Oct 04, 2021 - 03:33 PDT
Investigating
We detected issue with processing BCH transactions and currently investigating.
Posted Oct 03, 2021 - 21:36 PDT
This incident affected: Digital Assets (Bitcoin Cash).