Issues with downloading encrypted documents from https://www.bitgo.com/encrypt/ and https://www.bitgo.com/trustencrypt/
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 16:15 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 10, 2022 - 14:58 PDT
Update
We are continuing to investigate this issue.
Posted Aug 10, 2022 - 12:47 PDT
Investigating
We are currently investigating an issue with downloading encrypted documents from https://www.bitgo.com/encrypt/ and https://www.bitgo.com/trustencrypt/
Posted Aug 10, 2022 - 12:47 PDT