Delay in processing transactions for avaxc

Incident Report for BitGo

Resolved

This incident has been resolved.
Posted Nov 16, 2025 - 03:50 PST

Investigating

Delay in processing transactions for avaxc
Posted Nov 16, 2025 - 02:01 PST
This incident affected: Digital Assets (Avalanche C-chain).