Intermittent issues submitting ETH and ERC-20 trades
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 22, 2023 - 16:11 PST
Investigating
We are currently investigating this issue.
Posted Feb 22, 2023 - 12:50 PST
This incident affected: Trade and Trade API.