Issue processing BTC transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 02, 2021 - 17:09 PDT
Update
We are continuing to investigate this issue.
Posted Nov 02, 2021 - 16:21 PDT
Investigating
Our engineering team is investigating an issue regarding issue processing BTC transactions.
Posted Nov 02, 2021 - 16:21 PDT
This incident affected: Digital Assets (Bitcoin).