Delays processing incoming ETH/ERC20 transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Dec 02, 2022 - 00:42 PST
Investigating
We are currently investigating this issue.
Posted Dec 01, 2022 - 23:53 PST
This incident affected: Digital Assets (Ethereum).