Intermittent slow performance and page timeouts in app.bitgo.com
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted May 24, 2022 - 21:52 PDT
Update
We have restored Trade and Trade API components. We are continuing to investigate this issue that impacts other components.
Posted May 24, 2022 - 19:02 PDT
Update
We are continuing to investigate this issue.
Posted May 24, 2022 - 18:27 PDT
Investigating
We are currently investigating the issue.
Posted May 24, 2022 - 18:23 PDT
This incident affected: Wallets, Trade, Trade API, and Portfolio & Tax.