Degraded performance processing ETH transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 16:26 PST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 16:15 PST
This incident affected: Digital Assets (Ethereum).