XLM Stellar Duplicate Transaction ID Error
Incident Report for BitGo
Resolved
We have resolved this issue, you should not see duplication of XLM transaction anymore on our platform.
Posted Jun 18, 2021 - 15:50 PDT
Identified
We have identified the issue and currently working on implementing a fix
Posted Jun 18, 2021 - 15:09 PDT
Investigating
Our team has been made aware of an issue related to the duplication/ replication of XLM transaction Id's. We are currently investigating this issue.
Posted Jun 18, 2021 - 00:48 PDT
This incident affected: Digital Assets (Stellar).