BCH Hard Fork
Incident Report for BitGo
Resolved
BCH Service is restored.
Posted Nov 16, 2020 - 22:44 PST
Investigating
Our BCH services are still offline for maintenance.
Posted Nov 16, 2020 - 06:57 PST
This incident affected: Digital Assets (Bitcoin Cash).