ETH Degraded Performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 13, 2021 - 20:35 PST
Investigating
We are currently investigating this issue.
Posted Feb 13, 2021 - 19:40 PST
This incident affected: Digital Assets (Ethereum).