BTC Degraded Performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 01:15 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2020 - 01:14 PDT
Investigating
Our BTC processing is experiencing some performance issues at this time. Our Engineering and DevOps teams are actively investigating this issue, and we will will provide updates here as they become available.
Posted Sep 08, 2020 - 00:47 PDT
This incident affected: Wallets and Digital Assets (Bitcoin).