There is an issue processing TRX transactions and we are currently looking into it.
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Apr 26, 2022 - 02:10 PDT
Investigating
We are currently investigating this issue.
Posted Apr 26, 2022 - 00:01 PDT
This incident affected: Digital Assets (Tron).