Issue processing XLM transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Oct 03, 2021 - 19:12 PDT
Investigating
We are currently investigating this issue.
Posted Oct 03, 2021 - 18:06 PDT