Issue processing transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Feb 03, 2021 - 08:30 PST
Investigating
We are currently investigating this issue. Transactions are getting processed slowly.
Posted Feb 03, 2021 - 08:19 PST
This incident affected: API.