BitGo TestNet degraded performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 23:47 PST
Investigating
BitGo TestNet degraded performance, unable to process transactions
Posted Nov 28, 2022 - 17:31 PST
This incident affected: Testnet.