BitGo TestNet degraded performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 22:15 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2022 - 21:07 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2022 - 21:06 PST
This incident affected: API, Wallets and Digital Assets (Ethereum).