Issue processing BTC transactions
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 17:51 PST
Investigating
We are currently investigating this issue.
Posted Nov 10, 2021 - 16:55 PST
This incident affected: Digital Assets (Bitcoin (V1), Bitcoin).