ETH Degraded Performance
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 16:26 PST
Investigating
Our ETH processing is experiencing some performance issues at this time. Our Engineering and DevOps teams are actively investigating this issue, and we will will provide updates here as they become available.
Posted Dec 22, 2020 - 10:04 PST
This incident affected: Digital Assets (Ethereum).