WBTC network is currently down
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Jun 16, 2021 - 06:10 PDT
Monitoring
A fix has been implemented and we are currently monitoring the situation
Posted Jun 16, 2021 - 02:12 PDT