We are experiencing issues with Algorand
Incident Report for BitGo
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 16:11 PDT
Monitoring
Our team internally is currently monitoring the results.
Posted Aug 10, 2022 - 09:26 PDT
Investigating
We are currently investigating the issue on our end
Posted Aug 10, 2022 - 08:31 PDT
This incident affected: API, Wallets and Digital Assets (Algorand).